PRODUCTS

4D V15

Smart Business App Development

warning: file_get_contents(http://www.telize.com/geoip/54.92.201.232) [function.file-get-contents]: failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found in /var/www/www.4d.com/docs/includes/common.inc(1762) : eval()'d code on line 4.
4D
As a company policy, 4D sells and supports not only its current version, 4D v15, but the previous version of the product line as well. If you’re still using 4D v15, you get the support you expect, and the migration guidance you'll want when the time comes.

Migrate

Did you know there's a newer version of the 4D product line available?  4D v16 gives you everything that 4D v15 has to offer, as well as new features that will make both developers and end users much more productive.

 

Learn about migrating to 4D v16

Develop

Start developing your applications using 4D’s intuitive development environment and integrated SQL database.

 

Learn more about developing with 4D

 

Compare development offers