Daten wiederherstellen

4D - Documentation   Français   English   German   Japanese   4D Server, Inhalt   Index   Back   Previous   Next

Version 11 (Geändert)


Mit dem in 4D integrierten Backup-Modul können Sie komplette Datenteile der Datenbank bei Zwischenfällen, egal welcher Art, wiederherstellen.

Zwischenfälle und Diagnose

Es gibt zwei Hauptkategorien für Zwischenfälle:

Unvorhergesehener Abbruch der Datenbank in Betrieb

Dieser Zwischenfall kann bei Stromausfall, Fehler im Betriebssystem, o.ä. passieren. Je nachdem, welchen Status der Daten-Cache im Augenblick des Zwischenfalls hat, sind zum Wiederherstellen der Datenbank unterschiedliche Operationen erforderlich:

- War der Cache leer, öffnet sich die Datenbank ganz normal. Alle Anderungen in der Datenbank wurden gespeichert. In diesem Fall ist keine besondere Operation erforderlich.

- Enthält der Cache Operationen, ist die Datenbank intakt. Sie müssen jedoch das aktuelle Logbuch integrieren, um den Zustand im Moment des Abbruchs wiederherzustellen.

- Sollte der Cache gerade auf die Festplatte geschrieben werden, ist die Datendatei wahrscheinlich beschädigt. In diesem Fall müssen Sie das letzte Backup wiederherstellen und das aktuelle Logbuch integrieren.

Verlust von Dateien der Datenbank

Dieser Zwischenfall kann bei fehlerhaften Sektoren auf der Festplatte, bei einem Virus, bei Bedienungsfehlern, o.ä. passieren.

Hier müssen Sie das letzte Backup wiederherstellen und das aktuelle Logbuch integrieren.

Um herauszufinden, ob eine Datenbank bei einem Zwischenfall beschädigt wurde, starten Sie einfach die Datenbank wieder mit 4D/4D Server. Das Programm führt selbst eine Prüfung durch und listet auf, welche Operationen zum Wiederherstellen ausgeführt werden müssen.

Im automatischen Modus werden diese Operationen direkt ausgeführt, ohne Eingreifen durch den Benutzer. Weitere Informationen dazu finden Sie im nächsten Absatz.

Haben Sie eine reguläre Backup-Strategie eingerichtet, finden Sie über die 4D Werkzeuge zum Wiederherstellen in der Regel die Datenbank in genau dem Zustand vor dem Zwischenfall vor. Zwei Haupt-Tools stehen zur Verfügung:

Wiederherstellen des Backup

Integration des Logbuchs

Beide Funktionen lassen sich auch miteinander kombinieren und automatisieren.

Automatisches Wiederherstellen

4D startet nach einem Zwischenfall automatisch die Prozedur zum Wiederherstellen der Datenbank. Das sind folgende Abläufe:

Automatisches Wiederherstellen

Automatische Integration des Logbuchs

Automatisches Starten der Datenbank nach Wiederherstellen

Sie können diese Abläufe in den Einstellungen der Datenbank auf der Seite Wiederherstellen unter dem Thema Backup einzeln aktivieren/deaktivieren:

Letztes Backup wiederherstellen, wenn Datenbank beschädigt

Mit dieser Option startet das Programm automatisch die Wiederherstellung der Daten des letzten gültigen Backup der Datenbank, wenn beim Hochfahren der Datenbank eine Unregelmäßigkeit festgestellt wird. Der Benutzer selbst muss nichts ausführen; die Operation wird im Logbuch des Backup vermerkt. Weitere Informationen dazu finden Sie im Abschnitt Backup Journal.

Hinweis: Beim automatischen Wiederherstellen wird nur die Datendatei wiederherstellt. Soll das auch für die angefügten Dateien oder die Strukturdatei gelten, müssen Sie eine manuelle Wiederherstellung ausführen.

Bei automatischer Wiederherstellung werden folgende Schritte ausgeführt:

4D/4D Server gibt zuerst der beschädigten Datendatei einen anderen Namen.

4D/4D Server entnimmt die Datendatei des letzten Backup und speichert sie an der Stelle der vorigen Datei.

Ist die Option "Letztes Logbuch integrieren, wenn Datenbank unvollständig" markiert, integriert 4D bei Bedarf das Logbuch. Weitere Informationen dazu finden Sie im Absatz "Letztes Logbuch integrieren, wenn Datenbank unvollständig".

Ist die Option "Datenbank nach automatischer Wiederherstellung starten" markiert, startet 4D/4D Server die wiederhergestellte Datenbank. Weitere Informationen dazu finden Sie im Absatz "Datenbank nach automatischer Wiederherstellung starten".

Letztes Logbuch integrieren, wenn Datenbank unvollständig

Ist diese Option markiert, integriert das Programm automatisch das Logbuch, wenn eine wiederhergestellte Datenbank geöffnet wird. Der Benutzer selbst muss nichts ausführen.

Beim Öffnen einer Datenbank wird das aktuelle Logbuch automatisch integriert, wenn 4D/4D Server feststellt, dass die im Logbuch gespeicherten Operationen in den Daten nicht vorhanden sind. Das passiert z.B. bei Stromausfall, wenn es Operationen im Daten-Cache gibt, die noch nicht in den Hauptspeicher übertragen wurden.

Hat beim Wiederherstellen einer Datenbank das aktuelle Logbuch bzw. Logbuch des Backup dieselbe Nummer wie das Backup, das im gleichen Ordner gespeichert ist, prüft 4D/4D Server seinen Inhalt. Enthält es Operationen, die nicht in der Datendatei enthalten sind, wird es integriert.

Auf Benutzerseite erscheint kein Dialogfenster, die Operation läuft vollkommen automatisch ab. Ziel dabei ist, die Verwendung so einfach wie möglich zu machen. Die Operation wird im Logbuch des Backup vermerkt. Weitere Informationen dazu finden Sie im Abschnitt Backup Journal.

Backup manuell wiederherstellen

Sie können den Inhalt eines Archivs, das vom Backup-Modul erstellt wurde, manuell wiederherstellen. Manuelles Wiederherstellen ist z.B. erforderlich, um den Archivinhalt im Ganzen zu reproduzieren (Strukturdateien und/oder angehängte Dateien) oder zur Ausführung von Suchläufen in den Archiven. Wiederherstellen kann auch mit Integration des aktuellen Logbuchs erfolgen.

Hinweis: Sie können 4D so einstellen, dass die Datenbank bei einen Zwischenfall, egal welcher Art, wiederhergestellt wird. Weitere Informationen dazu finden Sie im Abschnitt Daten wiederherstellen.

Sie können die manuelle Wiederherstellung von Backup über den Standard Öffnen-Dialog oder die Seite Wiederherstellen im Maintenance- und Security-Center (MSC) ausführen:

Über den Standard Öffnen-Dialog können Sie jedes Archiv wiederherstellen. Dies wird nachfolgend beschrieben.

Über das MSC können Sie weitere Optionen wählen, z.B. den Inhalt des Archivs einsehen. Dagegen können Sie hier nur Archive der geöffneten Datenbank wiederherstellen.

Über Öffnen-Dialog

Um eine Datenbank über den Standard Öffnen-Dialog manuell wiederherzustellen:

1. Starten Sie 4D und wählen im Menü Datei/Ablage den Befehl Wiederherstellen.

Für diesen Befehl muss nicht zwingend eine Datenbank geöffnet sein.

ODER

Führen Sie in einer 4D Methode den Befehl RESTORE aus.

Auf dem Bildschirm erscheint ein Standard Öffnen-Dialog, in dem Sie angeben, welche Backup-Datei (.4bk) bzw. welches Logbuch (.journal) wiederhergestellt werden soll.

2. Wählen Sie die gewünschte Datei und klicken auf die Schaltfläche Wiederherstellen:

Auf dem Bildschirm erscheint folgendes Dialogfenster.

Hier können Sie den Zielordner angeben, in dem die Dateien wiederhergestellt werden.

4D stellt die Dateien standardmäßig in einem Ordner mit Namen „Archivname" (ohne Endung) wieder her, der neben dem Archiv liegt. Sie können auf die Schaltfläche […] klicken, um ein anderes Ziel festzulegen.

Hat das aktuelle Logbuch bzw. Logbuch des Backup dieselbe Nummer wie das Backup, das im gleichen Ordner gespeichert ist, prüft 4D seinen Inhalt. Enthält es Operationen, die nicht in der Datendatei enthalten sind, fragt das Programm, ob Sie diese Operationen integrieren wollen.

Hinweis: Die Integration erfolgt automatisch, wenn die Option zum Integrieren des Logbuchs markiert ist. Weitere Informationen dazu finden Sie im Absatz "Letztes Logbuch integrieren, wenn Datenbank unvollständig".

3. (Optional) Klicken Sie auf die Schaltfläche OK, um das Logbuch in die wiederhergestellte Datenbank zu integrieren.

Sind die Operationen zum Wiederherstellen und Integrieren korrekt abgelaufen, zeigt 4D die Meldung, dass der Vorgang erfolgreich abgeschlossen wurde.

4. Klicken Sie auf die Schaltfläche OK.

Der Zielordner wird angezeigt. 4D legt während der Wiederherstellung alle Backup-Dateien in den Zielordner, egal an welcher Stelle auf der Festplatte die Orginaldateien beim Starten des Backup liegen. So finden Sie die Dateien leichter.

Über MSC

Sie können ein Archiv der aktuellen Datenbank über das Maintenance- und Security-Center (MSC) wiederherstellen. Hier können Sie auch verschiedene Optionen zur Durchführung festlegen.

Gehen Sie folgendermaßen vor:

Wählen Sie im Menü Hilfe den Befehl Maintenance- und Security-Center oder klicken Sie in der 4D Werkzeugleiste auf das Icon MSC und öffnen die Seite Wiederherstellen.

Der linke Bereich enthält die vorhandenen Backups der Datenbank. Wählen Sie hier ein Backup aus, erscheinen im rechten Teil des Fensters Informationen über dieses Backup:

Pfad: Vollständiger Pfadname der gewählten Backup-Datei. Mit der Schaltfläche Anzeigen öffnen Sie die Backup-Datei in einem Systemfenster.

Datum und Zeit: Datum und Uhrzeit des Backup.

Inhalt: Inhalt der Backup-Datei. Neben jedem Eintrag in der Liste gibt es ein Ankreuzfeld, über das Sie angeben, ob er wiederhergestellt werden soll. Über die Schaltflächen Nichts aktivieren oder Alles aktivieren stellen Sie die Liste der Einträge zusammen, die Sie wiederherstellen wollen.

Zielordner für wiederherstellte Dateien auswählen: Ordner, in dem die wiederhergestellten Dateien abgelegt werden. 4D legt die wiederhergestellten Dateien standardmäßig in einem Ordner mit Namen Archivname (ohne Endung) ab, der auf derselben Ebene wie das Archiv liegt. Wollen Sie das Ziel ändern, klicken Sie unter dem Bereich auf die Schaltfläche [...], und geben einen anderen Ordner an.

Mehrere Logbücher nacheinander integrieren

Sie können mehrere Logbücher hintereinander in die Datenbank integrieren. Haben Sie z.B. 4 Logbücher passend zu 4 Backups der Datenbank, können Sie das erste Backup wiederherstellen und dann die Logbücher der Reihe nach integrieren. Auf diese Weise können Sie z.B. eine Datei wiederherstellen, auch wenn die letzten Backup-Dateien fehlen.

Ist diese Option markiert, zeigt 4D nach dem Wiederherstellen den Standard Öffnen-Dialog. Hier können Sie das entsprechende Logbuch auswählen. Der Öffnen-Dialog erscheint erneut nach jeder Integration, bis er abgebrochen wird.

Logbuch manuell integrieren

Ist die Option für automatisches Integrieren des Logbuchs nicht aktiv, erscheint beim Öffnen der Datenbank eine Meldung, wenn 4D feststellt, dass das Logbuch mehr Operationen enthält als in der Datenbank ausgeführt wurden.

Damit dieser Vorgang funktioniert, muss 4D/4D Server auf das Logbuch am aktuellen Zielort zugreifen können.

Sie entscheiden selbst, ob Sie das aktuelle Logbuch integrieren wollen.

Operationen rückgängig machen

4D bietet eine Funktion, über die sich Operationen, die im Logbuch aufgeführt sind, rückgängig machen lassen. Der Vorgang ähnelt dem Widerrufen in mehreren Stufen. Er ist besonders hilfreich, wenn versehentlich ein Datensatz aus der Datenbank gelöscht wurde.

Das ist nur durchführbar, wenn die Datenbank ein Logbuch hat.

Um eine Datenbank in einem früheren Stadium wiederherzustellen:

1. Wählen Sie im Menü Hilfe den Befehl Maintenance- und Security-Center und öffnen Sie die Seite Zurückfahren. Auf dem Bildschirm erscheint folgendes Dialogfenster:

Hinweis: Nur Administrator und Designer der Datenbank sind berechtigt, das Logbuch zu überprüfen.

2. Wählen Sie die Zeile, nach der alle Operationen annulliert werden sollen.

Die Operation der gewählten Zeile bleibt als letzte erhalten. Wollen Sie z.B. einen Löschvorgang aufheben, wählen Sie die direkt davor liegende Operation. Diese bleibt dann erhalten, alle nachfolgenden Operationen werden zurückgefahren.

3. Klicken Sie auf die Schaltfläche Zurückfahren.

Auf dem Bildschirm erscheint ein Dialogfenster zum Bestätigen.

4. Klicken Sie auf die Schaltfläche OK.

Die Daten werden dann in dem Stadium wiederhergestellt, das zum Zeitpunkt der gewählten Operation galt.

Arbeitsweise

Klickt der Benutzer auf die Schaltfläche Zurückfahren, schließt 4D die aktuelle Datenbank und stellt das letzte Backup der Daten der Datenbank wieder her. Die wiederhergestellte Datenbank wird dann geöffnet. 4D integriert die Operationen des Logbuchs bis zur gewählten Operation.

Wurde die Datenbank noch nicht gesichert, startet 4D mit einer leeren Datendatei.


4D - Documentation   Français   English   German   Japanese   4D Server, Inhalt   Index   Back   Previous   Next