Blogues

QUESTIONS FRÉQUENTES

warning: file_get_contents(http://www.telize.com/geoip/54.198.143.210) [function.file-get-contents]: failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found in /var/www/www.4d.com/docs/includes/common.inc(1762) : eval()'d code on line 4.

I need to buy a 12-month renewal of 4D Web 2.0 Pack before my current subscription expires. What happens if I don't?

If you decide to not continue your subscription, you will still have full access to the version of the software you currently have and it will continue to function. However, you won't have access to any bug fixes, new features, or new parts of the product that we release after your subscription expires.


If you stop subscribing and then decide to resume a subscription after your current one has expired, you can ‘catch-up' by calling your 4D account representative or 4D Customer Service.

Can I develop 4D web applications without 4D Ajax Framework?

Yes, of course! We think that once you've tried the tools 4D Ajax Framework has to offer, you'll love them so much that you won't want to do Web development without them, but they are not required in order to develop rich Internet applications with 4D.

Will the apps I create with 4D Ajax Framework run only on 4D Server, or can I use 4D Runtime Single User?

4D web applications can run on either, as long as you have a copy of 4D Web Server in place.

Why shouldn't I use a free Ajax framework like Dojo or YUI?

There's no reason you can't. However, there are some things that 4DAF does that those other frameworks simply do not offer. For example, we've focused 4D Ajax Framework on providing powerful query handling and data organizing, such as our data tree and calendar controls.

Is a web application built with 4D Ajax Framework meant to replace 4D Client?

Not at all. We've introduced 4D Ajax Framework to give you more choices, not less. Using a web browser as a 4D client is meant to be an additional option to go alongside of using the existing 4D Client.

I have a large, complex 4D structure and I don't want to add any new tables or forms to it. What will 4D Ajax Framework do to my structure?

Nothing. You need to add one component to the application, but the rest of your data structure doesn't need to be touched.

How is 4D Ajax Framework different from other frameworks?

The 4D Ajax Framework is a multi-layered framework with deep integration into the 4D environment. It has been designed to complement the existing 4D developer environment. Ajax frameworks that are not system-specific do not have the same level of integration. They work well for basic functions but are less useful for in-depth 4D application development or integration. For example, 4D Ajax Framework recognizes and can use an existing 4D security user/group structure. Other frameworks don't.

I'm having a conflict with 4D for Flex and Adobe AIR

“I tried to create an AIR project using 4D for Flex but there seems to be a conflict. It looks like some of 4D for Flex's classes conflict with AIR's own SQL classes. SQLConnect is one of them.”


1) The approach of using what we call the Flash layer is not supported as it is explained in the manual.

 

2) If you still want to use this API, you can fully qualify this function as a workaround:

 

Where's the French localization file in 4D for Flex?

“Any beginner Flex user with a fresh FB3 install wil not have a fr_fr locale and will not be able to compile/run the demos.”

 

Adobe does not provide the "fr_FR" locale (only English & Japanese locales are provided by default).  You will have to create your own locale by using the "copylocale" tool provided by Adobe.

 

Using the "Adobe Flex 3 SDK Command prompt", just type: copylocale en_US fr_FR

How do I resolve a security alert in 4D for Flex?

You may receive the following error:

 

Error #2048
Security sandbox violation
http://localhost8080/SpendingsUI.swf cannot load data from localhost1919

This is due to a change in the Adobe Flash Player Security Model starting from version 9.0.124. See:

http://www.adobe.com/support/security/bulletins/apsb08-11.html
 

To fix this issue, you will need to use 4D Server v11 SQL Release 2.